Blackboard supports recent versions of the four main browsers

Firefox logo 128x128
Firefox

Google Chrome Logo 128x128
Chrome
Safari logo 128x128
Safari
Internet Explorer logo 128x128
Internet Explorer

Automatically updated browsers

Blackboard supports the latest release of:

  • Firefox
  • Chrome

Traditionally released browsers

Blackboard supports the following versions:

  • Safari v7, v6 – on OS X only.
  • Internet Explorer v11, v10, v9
    See note below

We recommend using Chrome or Firefox to access Blackboard

There is more detailed information on supported browsers, and Blackboard’s browser support policy on their help site.

What browser am I using?

If you don’t know what web browser you are using, you can find out at whatbrowser.org

Internet Explorer compatibility view

Blackboard should not be run under compatibility view in Internet Explorer. If this view is on, you will see the words Top frame table at the top of the page, and other items will look incorrect or our of place.

To switch off compatibility view, click the button in the toolbar:

IE9 Compatibility View Toolbar Button

There’s more information about how to turn off compatibility view on Blackboard’s help site.

2 revisions

  • 1
  • 1

Page information

  • Published: 3 years ago
  • Updated: 8 months ago